Epic Browser: Attachment Errors - "An Open File Has Been Detected"

Error: "An Open File Has Been Detected"

Workflows to recreate:

Workflow #1:
  1. Attach a Microsoft Office file (.docx, .xlsx, .pptx) or PDF document to a client in Applied Epic.
  2. Open the attached file from the client's attachment list.
  3. Close the attachment file using File, Close, or using the small 'x' in the top-right corner of the program. This closes the file but leaves the program open.
  4. Attempt to close the client window. A message displays, which indicates "An open file has been detected. Please close this file before continuing.
"Workflow #2:
  1. Attach a Microsoft Office file (.docx, .xlsx, .pptx) or PDF document to a client in Applied Epic.
  2. Open the attached file from the client's attachment list.
  3. Open another file of the same type from a location outside of Epic.
  4. Close the attachment opened from within Epic, but leave the second file open.
  5. Attempt to close the client window. A message displays, which indicates "An open file has been detected. Please close this file before continuing."
 

Cause

When you open an Office document from a client's attachment list and then open a file of the same type from outside of Epic, Office automatically merges the new file into the existing program instance that Epic opened. 

For example:
  • If you make edits to the Epic attachment (an Excel spreadsheet) and close only that file, you will not be prompted to save the changes to Epic until all instances of the program sharing that same Excel.exe process are closed (other xls files, for example).
  • If you attempt to close the client frame while the other spreadsheet is still open (and therefore the EXCEL.exe process is still open), you will get a validation message in Epic indicating that an open file has been detected. Again, to close the client, you must first close all instances of the program sharing the same EXCEL.exe process.
This situation occurs because products such as Microsoft Office and Adobe Acrobat Reader DC force multiple instances of their program to merge into a single process. Epic cannot prevent this from happening. Use the workarounds below to try to prevent this message. 
 

Solution

If the user is leaving the Adobe Acrobat/Word/Excel open and getting this error: Try closing the program (Adobe Acrobat/Word/Excel) with the X in the upper right corner rather than closing the individual file. This will prevent the "Open File" errors. 

If the user is closing Adobe Acrobat/Word/Excel and still getting this error:

  • Contact the helpdesk as we will have to correct this issue - helpdesk@higusa.com
  • Clear this error by accessing Windows Task Manager and going to the Processes tab. End Process on the (Adobe Acrobat/Word/Excel) program. The Attachment screen in Applied Epic should now close without the "Open File" errors.

 

 
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